Kleyton Mines

Find a bug? Report it here.

Kleyton Mines

Postby Connor MacManus on Tue Jun 03, 2008 5:06 pm

When digging tunnels in the mines the links aren't working properly. For instance

Below is a diagram to indicate the problem.

1 4
| |
2 \ 3

I started in room 1 and dug south to room 2. From room 2 I dug down into room three. From room three I dug north into room four.

Instead of creating something which should have resembled the above diagram (i.e only able to access room four from room three) a down exit was automatically created from room one. While this is physically correct if I had dug a tunnel down from room one, it shouldn't have been automatically linked when I dug room four.
Connor MacManus
 
Posts: 6
Joined: Wed May 28, 2008 12:02 pm

Re: Kleyton Mines

Postby Drew Hopkins on Tue Jun 03, 2008 6:22 pm

Good point, an unexpected effect. I'll try to work up a fix soon, but it likely won't affect existing rooms/exits. Thanks for noticing this.

Drew.
User avatar
Drew Hopkins
Site Admin
 
Posts: 20
Joined: Tue May 27, 2008 9:39 am
Location: Dallas, TX

Re: Kleyton Mines

Postby Connor MacManus on Tue Jun 03, 2008 6:40 pm

I'm not sure if it's the same problem (it probably is) but I had the same thing occur again while digging a north exit and then a west exit.

3 -- 2
xx\x| (x's is undug space)
xxx\1

I dug north from room one into room two. From there I dug west into room three. When I finally got into room three there was a diagonal link between room one and three.

Probably the same problem, but I figured I would report it.
Connor MacManus
 
Posts: 6
Joined: Wed May 28, 2008 12:02 pm


Return to Typo & Bug Reporting

Who is online

Users browsing this forum: No registered users and 1 guest

cron